0 212 951 05 08   bilgi@ofisdata.com

Yazılarımız

OfisData

EXCEL FORMÜLLERİ

İşinizi Kolaylaştıracak 10 Excel Formülü

Excel’de işlerinizi manuel olarak yaparak daha çok zaman harcamayın. Excel formüllerini kullanarak işinizde kaybettiğiniz zamanı azaltacak ve daha doğru veri raporları çıkarmanıza yardım edecek Excel Formüllerini kullanmanın bir çok yöntemi var.

Kesinlikle Bilinmesi Gereken Excel Formülleri

1- TOPLA

Formül: =TOPLA(5,5) veya =TOPLA(A1, B1) veya =TOPLA(A1:B5)

TOPLA formülü tam olarak odaklanmak istediğiniz komutu yerine getirir. 2 veya daha fazla sayıyı birlikte girmenize olanak verir. Aynı zamanda hücre referanslarını da bu formül içinde kullanabilirsiniz.

Yukarıda farklı örnekler gösterilmiştir. Sayıları parantez içinde virgülle ayrılmış yerlerinde farklı şekillerde kolon ve satır kodlarını göstererek kullanabilirsiniz.

2- BAĞ_DEĞER_SAY

Formül: =BAĞ_DEĞER_SAY(A1:A10)

Bağımsız değişkenler listesinde kaç tane sayı bulunduğunu sayar.

Excel Formülleri

Formül sadece sayılarda çalışır.

Excel Formülleri

Sadece sayıların olduğu hücreleri sayar.

3- BAĞ_DEĞ_DOLU_SAY

Formül: =BAĞ_DEĞ_DOLU_SAY(A1:A10)

Bağımsız değişkenler listesinde kaç tane değer bulunduğunu sayar.

BAĞ_DEĞ_DOLU_SAY formülü bütün veri türlerinde çalışır.

Excel Formülleri

4- UZUNLUK

Formül: =UZUNLUK(A1)

UZUNLUK formülü bir metin dizesindeki karakter sayısını verir. Dikkatli olun; çünkü her boşluk karakter olarak kabul edilmektedir.

Excel Formülleri

Formül sonuçları arasındaki farka dikkat edin. Boşluksuz karakter sayısı 10 iken, boşluklu karakter sayısı 12’dir.

5- KIRP

Formül: =KIRP(A1)

Sözcükler arasındaki tek boşluklar dışında metinden tüm boşlukları kaldırır. Boşlukları düzenli olmayan, başka bir uygulamadan aldığınız metin üzerinde KIRP işlevini kullanırız.

KIRP formülü metindeki boşlukları kaldırır. KIRP formülü çok kullanışlı bir formüldür; çünkü veritabanından veri çekeceğiniz durumlarda ekstra boşlukları otomatik olarak kaldırır.

Excel Formülleri

I love Excel’in arkasına ekstra boşluk koyduk ve sonra KIRP formülünü kullandık. KIRP formülü ekstra boşluğu kaldırdı.

6- SAĞDAN, SOLDAN, PARÇAAL

Formüller: =SAĞDAN(Karakterlerin Numarası ve Metni), =SOLDAN(Karakterlerin Numarası ve Metni), =PARÇAAL(Karakterlerin Numarası, Başlangıç Numarası ve Metni).

(Not: Bu formüllerde metin yazan her yerde aynı zamanda hücre referansı da kullanabilirsiniz.)

Bu formüller, bir metin dizesinden belirtilen sayıda karakteri geri çağırır. SAĞDAN size metin dizesinin sağından karakter sayısını verir. SOLDAN size metin dizesinin solundan karakter sayısını verir. PARÇAAL ise bir metin dizesinden belirli sayıda karakteri belirttiğiniz konumdan başlamak üzere verir.

Ayrıca metin_başlat formülü bir metinden metin dizesi alır. İşlev parametreleriyle başlangıç noktası ve alınacak harf sayısı belirlenebilir.

Excel Formülleri

SOLDAN formülünü kullanarak ilk kelimeyi aldık. A1 hücresine baktığımızda soldan ilk karakteri çekmiş olduk. Bu da bize I love Excel cümlesinden “I” kelimesini verdi.

PARÇAAL formülünü kullanarak ortadaki kelimeyi aldık. A1 hücresine baktığımızda 3. karakterden itibaren 5 karakter çağırması için kodu yazdık ve I love Excel’den “love” kelimesini çağırmış olduk.

SAĞDAN formülünü kullanarak son kelimeyi aldık. A1 hücresine baktığımızda saüdan son karakteri çekmiş olduk. Bu da bize I love Excel cümlesinden “Excel” kelimesini verdi.

7- DÜŞEYARA

Formül: =DÜŞEYARA(bakılan_değer, tablo_dizisi, sütun_indis_sayısı, aralık_bak)

Excel’de en çok kullanılan fonksiyonlardan birisi DÜŞEYARA fonksiyonudur. Tablo dizisinin ilk sütununda belirli bir değeri arar ve tablo dizisindeki başka bir sütundan aynı satır değerini döndürür.

Bakılan_değer: Tablo dizisinin ilk sütununda aranacak değer. Bakılan_değer bir değer veya başvuru olabilir. Bakılan_değer, tablo_dizisinin ilk sütunundaki en küçük değerden daha küçükse, DÜŞEYARA fonksiyonu #YOK hata değerini döndürür.

Tablo_dizisi: İki veya daha çok veri sütunu. Aralığa veya aralık adına bir başvuru kullanır. Tablo_dizisinin ilk sütunundaki değerler, bakılan_değer tarafından aranan değerlerdir. Bu değerler metin, sayı veya mantıksal değerler olabilir. Büyük harf ve küçük harfle yazılmış metinler eşdeğerdir.

Sütun_indis_sayısı: İçinden uyan değerin döndürülmesi gereken tablo_dizisindeki sütun sayısı. Sütun_indis_sayısı 1, tablo_dizisindeki ilk sütunun değerini verir; sütun_indis_sayısı tablo_dizisindeki ikinci sütunun değerini verir ve böyle devam eder.

Aralık_bak: DÜŞEYARA fonksiyonunun tam eşleşme mi yoksa yaklaşık eşleşme mi bulmasını istediğinizi belirten mantıksal değer:

DOĞRU'ysa veya belirtilmemişse, tam veya yaklaşık eşleşme döndürülür. Tam eşleşme bulunamazsa, bakılan_değerden küçük olan sonraki en büyük değer döndürülür.

YANLIŞ'sa, DÜŞEYARA fonksiyonu yalnızca tam eşleşmeyi bulur. Bu durumda, tablo_dizisinin ilk sütunundaki değerlerin sıralanması gerekmez. **Tablo_dizisinin ilk sütununda bakılan_değerle** eşleşen iki veya daha çok değer varsa, bulunan ilk değer kullanılır. Tam eşleşme bulunamazsa, #YOK hata değeri döndürülür.

Örneğin; 2 tane listeniz var. 1. listede satış personellerinin numarası ve çeyrek zamanda geliri 2. listede satış personelinin isimleri ve gelirleri yazılıyor. Listelerde yer alan satış personelinin isimleri ile gelirlerini birbirleriyle eşleştirmek istiyorsunuz. Bu işlemi elle yapmak çok karmaşıktır ve oldukça zaman alabilir.

İlk olarak listelere bakacak olursak; ilk liste A1’den B13’e ikinci liste ise D1’den E25’e gidiyor.

C1 hücresi için şu formülü yazıyoruz. =DÜŞEYARA(B18, $A$1:$B$13, 2, YANLIŞ)

B18 = bakılan_değer (Satış personeli numaraları. Bu numara iki listede birden görünür.)

$A$1:$B$13 = “tablo_dizisi” Bu alan; bakılan_değer için en soldaki sütunda (bu durumda sütun E) formülü aramak istediğim alandır. F’ye gittim çünkü

2 = indis sayısı. Bu formül eşleşme durumunda sütun numaralarının en soldaki sütundan ne kadar uzakta olması gerektiğini anlatıyor. Eğer tablo dizisinin bakılan_değer ve en soldaki sütun arasında bir eşleşme bulursanız aynı satırda tablonun 2. sütununa dönmüş olursunuz. (1. sütun her zaman en soldaki sütundur, 1 ile başlar 0 ile değil! )

YANLIŞ = Tam bir eşleşme için sadece değerini döndürmek istediğiniz formülü söyler.

Sonra formülü ilk listenin yanındaki C sütunu içindeki hücrelere kopyala yapıştır yapıyorum. Sonra bu liste bana tam sıralı bir biçimde satış personelinin adını, numarasını ve çeyrek zamanda gelirlerini sıralı bir şekilde liste olarak vermiş olur.

Excel Formülleri

Düzenli bir satış personeli adı, numarası ve çeyrek zamandaki gelirlerini alabilmek için DÜŞEYARA formülünü kullandım ve 1. ve 2. listeleri birbirleriyle eşleştirmiş oldum.

DÜŞEYARA formülü biraz karmaşık fakat en kullanışlı formüllerden birisidir. DÜŞEYARA formülü ve Excel ile ilgili daha fazla bilgi öğrenmek istiyorsanız OfisData Excel Eğitimlerine katılabilirsiniz.

8- EĞER

Formül: =EĞER(mantıksal_sınama;eğer_doğruysa_değer;eğer_yanlışsa_değer)

Eğer Excel’de birçok verinin analizini yapıyorsanız keşfetmeye çalıştığınız çok sayıda senaryo vardır. Veri, farklı durumlara farklı tepkiler veren yapıdadır.

Satış örneğiyle devam edelim. Satış personeline kota uyguladağımızı varsayalım. Daha önce DÜŞEYARA kullanarak gelirlerin yanlarına isimleri koyduk. EĞER ifadesi bize satış personelinin kotayı geçip geçmediğini söyler. Formülü girdi boyunca kopyalayıp yapıştırıyoruz. Böylelikle her satış personeli için kota değişmiş olur.

Excel Formülleri

9- ETOPLA, EĞERSAY, EĞERORTALAMA

Formüller: =ETOPLA(aralık, koşul, toplam_aralığı), =EĞERSAY(aralık, koşul), =AVERAGEIF(aralık, koşul, aralık_ortalama)

ETOPLA, belirli bir ölçütle belirlenen hücreleri ekler. Bu işlev bir veri aralığında herhangi bir değeri araştırmak için kullanılır. Arama düzenli ifadeleri destekler. "all." girebilirsiniz. Örneğin, "all" ve kendisinden sonra herhangi karakterleri içeren ilk konumu bulmak için.

Aynı zamanda bir düzenli ifade olan metni aramak için, her bir karakterden önce \ kullanmalısınız. Araçlar - Seçenekler - LibreOffice Calc - Hesapla. içerisinde düzenli ifadelerin otomatik değerlendirilmesi açıp kapatabilirsiniz.

EĞERSAY, bir aralık içindeki, belirli bir ölçütü karşılayan, boş olmayan hücreleri sayar. Bir hücre aralığındaki verilen kriterlere uyan hücre sayısını döndürür.

Excel Formülleri

Bu formülü örneğimizde; kotayı geçen personelleri, az farklave toplamda kotayı geçmiş personel sayısını görmek için kullandık.

10- BİRLEŞTİR

Formül: =BİRLEŞTİR("metin1"; ...; "metin30")

Birkaç metin öğesini bir metin öğesi olarak birleştirir.

İşiniz için Doğru Excel Formülünü Kullanın!

Excel’de 316 tane fonksiyon yapısı bulunmaktadır. Bu fonksiyonların hepsini aklımızda tutmamız mümkün değil. Fakat Excel’in fonksiyon bulma sihirbazını kullanarak bu fonksiyonlara kolayca erişmeniz mümkündür. Yapmanız gerken şey;

Excel’de formül çubuğunun yanındaki “fx” butonuna tıklıyoruz.

Excel Formülleri

Sonra karşımıza bir menü geliyor. Yapmak istediğiniz şeyi karşınızda çıkan boşluk satırına yazdığınızda ilgili formül ve fonksiyonları karşınıza getirebilirsiniz.

Excel Formülleri

Ben “boşluk” yazdığımda karşıma “KIRP” fonksiyonu çıktı.

Daha çok Excel Formülü!

Excel’de zaman formülleri ( ŞİMDİ, GÜN, AY, YIL, BUGÜN vb. ) veya, VE ve VEYA gibi birçok formül bulunmaktadır. İleri Excel uzmanlığı bu formülleri birleştirip kullanmaktan geçmektedir.

Siz de Excel’i kariyerinizde daha etkin olarak kullanmak istiyorsanız; İleri Excel Eğitimi sayfamızı ziyaret ediniz.

PAYLAŞ


 OFİS DATA